When logging into Windows 7, getting error “The trust relationship between this workstation and primary domain failed.”

This is the topic from a Microsoft-site here.

I want to make it as easy as possible with pictures here.

Sometimes it helps if you just restart the computer after 15 minutes. But if not, try the following.

This problem occured after I restored a backup at a computer, which is now longer recognized by the Domain Controller (DC). I think this has something to do with the timestamps and other stuff the DC is sending to its clients. If you want to know it exactly, just consult the web and maybe leave a comment so i can edit here in the article.

The easiest procedure for me is to

  • add a local admin (if you do not already have one. Domain Admins can not login in after this procedure!!)
  • remove the computer from the Domain and restart
  • Login with your local admin
  • join the computer again and restart

 

Here with pictures (It is german, but if you know your windows you can even read it in a foreign language 😉 ):

start compmgmt.msc with admin rights and add a user

Press [Win]+[Pause] or alternativly: Right click on your computer, select properties.

Change settings

On this screen select change

Select Workgroup and type in anything (like asdf 🙂 )

Confirm with OK

Restart the Computer and do the same again. But this time you do not select Workgroup, but instead Domain. Enter your domain. Note that you must have the rights to add a computer to a domain. Not every admin-like user has that.